Android开发要注意什么问题

2016/05/12 18:19:12    文章来源:互联网    浏览:202

一、对于SDK版本,我们有两种选择,如果你开发技术比较高兼容的最全面可以考虑使用Android 1.5 API Level为3的,高版本API使用Java反射调用,如果你考虑较简单可以使用Android 2.0或更高版本,发布时和API兼容性无关的可以设置androidmanifest.xml中的minSDK版本来解决。

二、对于固件版本而言Android开发网有两个问题要说,如果你追求固件升级速度使用谷歌自己的贴牌机型Nexus系列比较可靠,当然保证运行的可靠性建议使用英文版的官方固件,各种第三方固件并不是大多数人都是用的,可能因为提速或精简造成各种意料之外的问题,比如Android123曾经就测试过一款自制的ROM调试时产生很多莫名其妙的异常,刷回官方固件就很正常。

三、目前截止到2.3系统来看,最终安装的文件仍然是apk格式,界面和系统大多数功能均使用Java开发,但是稍微高端的应用考虑到性能和安全性使用C/C++是必要的,C/C++最终编译的so文件就相当于Windows下的dll动态库,需要一个宿主去加载调用,我们通过Java的JNI去调用这些本地方法,目前从NDK的版本来看Google不断增强和开放C++在Android开发的用处,以保证和iPhone这种使用本地语言开发出来的软件体验度不能差距太大。(文章内容参考互联网)




联系 · 华中科技

4008-930 523

售前QQ : 826999831 售后QQ : 61430188

地址:深圳市宝安区西乡街道宝安智谷科技创新园 A座816

网站定制开发需求表

X
建站类型:
开发类型:
项目预算:
功能模块:
 
阁下尊称:
联系电话:
所在城市: